Brother laser printer on Ubuntu

The Brother laser print are well supported on Ubuntu but unfortunately the drivers are not installed by default. The fastest way to get these printers working on Ubuntu is to install all brother-cups-wrapper-* drivers.

1 Response to “Brother laser printer on Ubuntu”


  • The reason these drivers cannot be installed by default is that they depend on the brother lpr drivers, which are not released under a FOSS license.

Comments are currently closed.